Expensify Classic Android App Outage

Incident Report for Expensify

Resolved

This incident has now been resolved. The Expensify app will update automatically on your device with the fixed version, but you can also download the update now here: https://play.google.com/store/apps/details?id=org.me.mobiexpensifyg
Posted Dec 16, 2024 - 10:10 UTC

Investigating

Our engineering team is aware of an instant crash issue affecting the most recent Android Expensify Classic app version. We are working on fixing this for customers. In the meantime, you should be able to access the web version (www.expensify.com) from a browser. Apologies for the inconvenience!
Posted Dec 15, 2024 - 22:40 UTC
This incident affected: Expensify Website And Mobile App.