Degraded Performance

Incident Report for Expensify

Resolved

This incident has been resolved.
Posted Jun 29, 2026 - 21:08 UTC

Update

The site is stable and we are monitoring performance for card imports.
Posted Jun 29, 2026 - 19:43 UTC

Monitoring

The site is stable and we are monitoring performance.
Posted Jun 29, 2026 - 17:00 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 29, 2026 - 16:18 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 29, 2026 - 16:02 UTC
This incident affected: Expensify Website And Mobile App.