General Site Instability Issues

Incident Report for Expensify

Resolved

This incident has been resolved.
Posted Dec 20, 2022 - 00:41 UTC

Monitoring

Site is stable, we are monitoring to make sure no further issues occur.
Posted Dec 19, 2022 - 20:15 UTC

Investigating

We are currently experiencing site slows and are investigating.
Posted Dec 19, 2022 - 17:38 UTC
This incident affected: Expensify Website And Mobile App.