Card Data temporarily unavailable

Incident Report for Expensify

Resolved

Credit Card updates are now back to normal.
Posted Dec 22, 2025 - 22:27 UTC

Identified

We've identified an issue with importing credit card data. This may mean your cards cannot be updated, or you can't assign new cards right now. Our team has identified the underlying issue and is working on a fix.
Posted Dec 22, 2025 - 20:55 UTC
This incident affected: Card Import and Feeds (Commercial Card Feeds, American Express, Bank of America, Brex, CapitalOne, Chase, Citi, Wells Fargo).