Degraded performance

Incident Report for Expensify

Resolved

This incident has been resolved.
Posted May 16, 2024 - 14:12 UTC

Update

We are continuing to monitor for any further issues.
Posted May 16, 2024 - 13:02 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 16, 2024 - 13:02 UTC

Investigating

The team is currently investigating the issue.
Posted May 16, 2024 - 12:41 UTC
This incident affected: Expensify Website And Mobile App.