Citi Cards not importing

Incident Report for Expensify

Resolved

The issue has been resolved. All Citi cards should have transactions import in the next 24 hours, and new accounts can be added.
Posted May 06, 2023 - 04:43 UTC

Identified

We have identified an issue where some Citi cards are not importing, and are redirecting to the Inbox when reconnecting (without connecting). We are actively working on a fix for this with Citibank.
Posted May 02, 2023 - 02:37 UTC
This incident affected: Card Import and Feeds (Citi).