Site Issue

Incident Report for Expensify

Resolved

The Expensify website is currently operational, and credit card connections are importing transactions.
Posted Jun 11, 2026 - 09:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results. However, credit card connection updates are currently paused, but our team are looking into this.
Posted Jun 10, 2026 - 22:29 UTC

Update

Some users will now be able to use the Expensify website, although systems are still recovering.
Posted Jun 10, 2026 - 20:09 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 10, 2026 - 19:33 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2026 - 18:49 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 10, 2026 - 17:31 UTC
This incident affected: Expensify Website And Mobile App and Expensify Travel.