General site performance issues
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted May 16, 2023 - 06:45 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 16, 2023 - 02:06 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 15, 2023 - 19:57 UTC
Identified
Some customers have reported minor site performance issues. Our team has identified the change that caused this issue, and is working on a fix.
Posted May 15, 2023 - 19:57 UTC
This incident affected: Expensify Website And Mobile App.