Happy Holidays!
Incident Report for Expensify
Resolved
Support response times are back to normal. Happy new year!
Posted Jan 04, 2022 - 10:31 UTC
Monitoring
Please be aware that from Thurs 23 Dec to Tues 4 Jan our chat support in Concierge and Guides callbacks might take a bit longer than usual, because of the holidays. Thanks for your patience, and happy holidays to you!
Posted Dec 22, 2021 - 01:00 UTC
This incident affected: community.expensify.com and Support Message Deliverability.