Degraded Performance
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted Jul 04, 2024 - 16:40 UTC
Monitoring
We’re aware of site instability issues and are working on resolving them as soon as possible. We apologize for the inconvenience.
Posted Jul 04, 2024 - 16:05 UTC
This incident affected: Expensify Website And Mobile App.