SMS Notifications Degraded

Incident Report for Expensify

Resolved

Thanks for your patience! Performance is back to normal.
Posted Jun 18, 2025 - 01:09 UTC

Investigating

We are currently experiencing a temporary degradation in our SMS notification service. As a result, some users may not receive expected SMS notifications during this time.
Posted Jun 16, 2025 - 20:14 UTC
This incident affected: Expensify Website And Mobile App.