Delayed support for the holiday period
Incident Report for Expensify
Resolved
Happy New Year! We are back up and running at full capacity.
Posted Jan 03, 2023 - 14:34 UTC
Monitoring
We have a reduced workforce over the holiday period so you may experience longer wait times than usual when contacting our support via email, chat or phone.

We wish you Happy Holidays and a sparkling fresh New Year - From all the team at Expensify!
Posted Dec 19, 2022 - 03:17 UTC