Website instability
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted Sep 17, 2024 - 11:55 UTC
Investigating
We are currently experiencing temporary site instability and are investigating.
Posted Sep 17, 2024 - 10:45 UTC
This incident affected: Expensify Website And Mobile App.