Issues creating new bank accounts
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted May 25, 2022 - 18:17 UTC
Monitoring
The third party has fixed the issue. We are closely monitoring for any additional impacts this may have had.
Posted May 25, 2022 - 16:17 UTC
Identified
We are currently investigating a problem regarding the creation of new bank accounts within Expensify, due to an outage by a 3rd party.
Posted May 25, 2022 - 15:03 UTC
This incident affected: Expensify Website And Mobile App.