General Site Instability Issues

Incident Report for Expensify

Resolved

This incident has been resolved.
Posted Dec 06, 2022 - 19:13 UTC

Monitoring

Our team is monitoring the fix. Customers may continue to experience intermittent slowness issues.
Posted Dec 06, 2022 - 01:31 UTC

Identified

Stability issues are still occurring intermittently. Our team is working on a solution.
Posted Dec 06, 2022 - 01:20 UTC

Investigating

Site is currently experiencing issues.
Posted Dec 05, 2022 - 18:32 UTC
This incident affected: Expensify Website And Mobile App.