Reduced support staffing over holiday period

Incident Report for Expensify

Resolved

Thanks for your patience! Support message deliverability is back to normal.
Posted Jan 09, 2025 - 03:33 UTC

Monitoring

Expensify is operating with reduced support staff over the holiday period. You may experience a delayed response, but we will reply as soon as possible. Happy holidays!
Posted Dec 20, 2024 - 01:24 UTC
This incident affected: Expensify Website And Mobile App.