Degraded Performance
Incident Report for Expensify
Resolved
We have resolved the instability at this time.
Posted Jun 04, 2024 - 12:50 UTC
Identified
We’re aware of site instability issues and are working on resolving them as soon as possible. We apologize for the inconvenience.
Posted Jun 04, 2024 - 10:09 UTC
This incident affected: Expensify Website And Mobile App.