Response times may be slower than usual

Incident Report for Expensify

Resolved

This incident has been resolved.
Posted Mar 21, 2023 - 13:42 UTC

Monitoring

Support staff in Europe and Australasia may not answer escalated queries as quickly as usual. This should return to normal next week.
Posted Mar 13, 2023 - 08:49 UTC
This incident affected: Support Message Deliverability.