Delayed Support Responsiveness
Incident Report for Expensify
Resolved
Thanks for bearing with us! We've reached a normal volume and reply time expectation.
Posted Mar 13, 2020 - 19:20 UTC
Monitoring
We're experiencing abnormally high support volume and you may notice slower than expected response times. We're working as fast as we can to clear the backlog and have approved additional support coverage for non-business hours. Please bear with us and we'll update this status when we are back to normal.
Posted Feb 12, 2020 - 20:33 UTC
This incident affected: Support Message Deliverability.