Partial Chase Connection outage
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted Jun 25, 2024 - 16:20 UTC
Identified
We’re updating our Chase integration, which may cause some Chase cards to stop importing temporarily. This should be resolved soon when our updates complete.
Posted Jun 24, 2024 - 22:20 UTC
Investigating
Some new and existing Chase banking connections are currently experiencing some issues. We're investigating the root cause.
Posted Jun 21, 2024 - 00:59 UTC
This incident affected: Card Import and Feeds (Chase).