Citi Connection Issue
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted May 10, 2022 - 12:25 UTC
Update
We are continuing to monitor for any further issues.
Posted May 06, 2022 - 18:31 UTC
Monitoring
Our team is aware of an issue impacting card imports for Citi.
Posted May 06, 2022 - 18:31 UTC
This incident affected: Card Import and Feeds (Citi).