Site outage

Incident Report for Expensify

Resolved

We identified the issue and pushed a fix. The site is back up.
Posted Nov 26, 2025 - 23:09 UTC

Investigating

We are currently experiencing a site outage. Our team is investigating to find and fix the root cause. We apologize for the inconvenience.
Posted Nov 26, 2025 - 23:00 UTC
This incident affected: Expensify Website And Mobile App.