Expensify Billing – Duplicate or Missing Charges/Cashback

Incident Report for Expensify

Resolved

This incident has been resolved. Should you have any questions, feel free to reach out to us via Concierge or at concierge@expensify.com.
Posted Mar 09, 2026 - 18:21 UTC

Identified

We are currently investigating this issue.
Posted Mar 03, 2026 - 19:56 UTC
This incident affected: Card Import and Feeds (Expensify Card).