Viewing Virtual Expensify Card details has been temporarily disabled.
Incident Report for Expensify
Resolved
The ability to view card details for virtual Expensify Cards has been restored.
Posted Jan 17, 2025 - 20:23 UTC
Identified
The ability to view Virtual Expensify Card details has been disabled temporarily. You can continue to use your Virtual Expensify Card details if they are saved or added to a third party wallet such as Apple Pay or Android Pay. We apologize for the inconvenience.
Posted Jan 14, 2025 - 22:47 UTC
This incident affected: Card Import and Feeds (Expensify Card).