General site performance issues
Incident Report for Expensify
Resolved
Thanks for your patience! Performance is back to normal.
Posted Sep 21, 2023 - 18:02 UTC
Update
We are continuing to investigate this issue.
Posted Sep 21, 2023 - 16:47 UTC
Investigating
We’re aware of site instability issues and are working on resolving them as soon as possible. We apologize for the inconvenience.
Posted Sep 21, 2023 - 16:41 UTC
This incident affected: Expensify Website And Mobile App.