General Site Performance Issue
Incident Report for Expensify
Resolved
Thanks for your patience! Performance is back to normal.
Posted Oct 02, 2023 - 21:11 UTC
Investigating
We are currently investigating this issue.
Posted Oct 02, 2023 - 20:08 UTC
This incident affected: Expensify Website And Mobile App.