Service Outage
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted Nov 28, 2022 - 16:36 UTC
Identified
We are currently experiencing a service outage. Our team has identified the root cause and is taking corrective action. We apologize for the inconvenience.
Posted Nov 28, 2022 - 16:20 UTC
This incident affected: Expensify Website And Mobile App.