Degraded Performance

Incident Report for Expensify

Resolved

This incident has been resolved.
Posted May 12, 2026 - 19:35 UTC

Monitoring

We’re aware of site instability issues and are working on resolving them as soon as possible. We apologize for the inconvenience.
Posted May 12, 2026 - 18:53 UTC
This incident affected: Expensify Website And Mobile App, SmartScan, Report PDFs, Integration APIs, Support Message Deliverability, Expensify Chat and Messaging, SMS Notifications, Expensify Travel and Card Import and Feeds (Expensify Card, Commercial Card Feeds, American Express, Bank of America, Brex, CapitalOne, Chase, Citi, Wells Fargo).