Site is Down

Incident Report for Expensify

Resolved

We have resolved the issue, and are continuing to put steps in place to prevent further problems. We're sorry for the trouble here!
Posted Jun 28, 2021 - 19:00 UTC

Update

We are continuing to investigate this issue.
Posted Jun 28, 2021 - 18:47 UTC

Investigating

We are currently investigating this issue.
Posted Jun 28, 2021 - 18:30 UTC
This incident affected: Expensify Website And Mobile App.