Issue with uploading receipts
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted Nov 26, 2024 - 23:55 UTC
Identified
An issue with uploading receipts to expenses has been identified and our team is working on a fix.
Posted Nov 26, 2024 - 23:09 UTC
This incident affected: Expensify Website And Mobile App.