Site is down
Incident Report for Expensify
Resolved
We have identified and resolved the issue and the website is back online.
Posted Feb 25, 2022 - 21:12 UTC
Investigating
We are currently investigating the issue and are working to resume service.
Posted Feb 25, 2022 - 20:48 UTC
This incident affected: Expensify Website And Mobile App.