Site instability under investigation

Incident Report for Expensify

Resolved

We've resolved this issue now and are taking steps to reduce the likelihood that this will happen again. We're sorry for the impact on your day
Posted Sep 05, 2023 - 16:07 UTC

Update

We are continuing to monitor for any further issues.
Posted Sep 05, 2023 - 15:54 UTC

Monitoring

We've identified the source of instability, and the site should be stable again now. Any background processes (like emails sent from Expensify) should also be catching up. Sorry for the trouble there!
Posted Sep 05, 2023 - 15:54 UTC

Investigating

We are currently investigating reports of site instability using Expensify's website and mobile app. We'll update once we have a fix in place, and we're sorry for the trouble here
Posted Sep 05, 2023 - 15:43 UTC
This incident affected: Expensify Website And Mobile App.