Some GBP payments are incorrectly showing as unsuccessful in Expensify
Incident Report for Expensify
Resolved
All GBP billing owners have had their accounts fixed and any amounts owed are settled or refunded.
Posted Apr 26, 2022 - 09:35 UTC
Update
We have extended the grace period for all GBP billing owners until April 19th. Billing owners will continue to see a balance owed, but this will be cleared when Expensify deploys the fix for this issue.

If you can see that Expensify has charged your card on file, DO NOT attempt to update the billing card to another credit or debit card.
Posted Apr 07, 2022 - 11:56 UTC
Identified
Some payments for Expensify services in GBP have been processed, but those successful payments are not reflected in Expensify, and billing owners are incorrectly shown a banner stating they have a balance owed.

Clearing the balance also appears to fail in some instances.

Changing the billing card sometimes is successful, but still shows as failing within Expensify.
Posted Apr 07, 2022 - 11:54 UTC