Citibank Scheduled Maintenance
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted Jun 10, 2022 - 10:11 UTC
Monitoring
Citi are undergoing scheduled maintenance between June 9th 11PM ET and June 10th 5AM ET. Please be aware that card connections may be affected during this time.
Posted Jun 10, 2022 - 05:21 UTC
This incident affected: Card Import and Feeds (Citi).