Degraded Performance
Incident Report for Expensify
Resolved
Thanks for your patience! Performance is back to normal.
Posted Aug 13, 2024 - 14:23 UTC
Investigating
We’re aware of site instability issues and are working on resolving them as soon as possible. We apologize for the inconvenience.
Posted Aug 13, 2024 - 14:11 UTC
This incident affected: Expensify Website And Mobile App.