Degraded Performance
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted Aug 01, 2023 - 15:23 UTC
Update
We are continuing to investigate this issue.
Posted Aug 01, 2023 - 15:22 UTC
Investigating
We’re aware of site instability issues and are working on resolving them as soon as possible. We apologize for the inconvenience.
Posted Jul 31, 2023 - 15:10 UTC
This incident affected: Expensify Website And Mobile App, SmartScan, and Support Message Deliverability.