Citi Connection Maintenance
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted Apr 22, 2022 - 15:07 UTC
Monitoring
Citi is currently performing maintenance on our connections, which should complete by 10AM EST.
Posted Apr 22, 2022 - 10:56 UTC
This incident affected: Card Import and Feeds (Citi).