Degraded Performance

Incident Report for Expensify

Resolved

This incident has been resolved.
Posted Apr 19, 2025 - 09:54 UTC

Investigating

We’re aware of site instability issues and are working on resolving them as soon as possible. We apologize for the inconvenience.
Posted Apr 19, 2025 - 08:36 UTC
This incident affected: Expensify Website And Mobile App.