Site Issue

Incident Report for Expensify

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 10:06 UTC

Update

A fix has been implemented and we are monitoring results. Emails (including login security codes) should now be working again. Please report any issues to Concierge (concierge@expensify.com).
Posted Jul 09, 2026 - 05:18 UTC

Monitoring

A fix has been implemented and we are monitoring results. Emails (including login security codes) should now be working again. Please report any issues to Concierge (concierge@expensify.com).
Posted Jul 09, 2026 - 05:18 UTC

Update

A fix has been implemented, and we are monitoring the results. However, email notifications (including magic codes) are not yet operational.
Posted Jul 08, 2026 - 22:19 UTC

Update

Site is experiencing instability. We are currently investigating this issue.
Posted Jul 08, 2026 - 21:14 UTC

Update

A fix has been implemented, and the Expensify website is currently operational. However, email notifications (including magic codes) are not yet operational. Our team is looking into this.
Posted Jul 08, 2026 - 20:27 UTC

Investigating

We are currently investigating this issue.
Posted Jul 08, 2026 - 19:35 UTC
This incident affected: Expensify Website And Mobile App and Outgoing emails.