General Site Performance Issue

Incident Report for Expensify

Resolved

Thanks for your patience! Performance is back to normal.
Posted Oct 03, 2023 - 17:40 UTC

Investigating

We are currently investigating this issue.
Posted Oct 03, 2023 - 13:57 UTC
This incident affected: Expensify Website And Mobile App.