Temporary Chase outage
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 00:02 UTC
Monitoring
Chase has alerted us to an internal outage and has suspended service temporarily, so you may experience a delay or issues importing Chase expenses. We’ll update the status page as soon as service has resumed for Chase imports.
Posted Apr 24, 2024 - 19:54 UTC
This incident affected: Card Import and Feeds (Chase).