Site Slows
Incident Report for Expensify
Resolved
Thanks for your patience! Performance is back to normal.
Posted Oct 05, 2023 - 19:28 UTC
Update
We are continuing to investigate this issue.
Posted Oct 05, 2023 - 19:25 UTC
Update
We are continuing to investigate this issue.
Posted Oct 05, 2023 - 19:24 UTC
Investigating
We are currently investigating this issue.
Posted Oct 05, 2023 - 14:56 UTC
This incident affected: Expensify Website And Mobile App.