Expensify Performance Degredation
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted Apr 04, 2020 - 09:00 UTC
Investigating
We are currently investigating the issue. We will update here with further information.
Posted Apr 04, 2020 - 08:28 UTC
This incident affected: Expensify Website And Mobile App.