Degraded performance
Incident Report for Expensify
Postmortem

For a full postmortem regarding our recent site outages, please check out this blog post by our founder and CEO, David Barrett. Thank you so much for your patience! Onward and upward.

Posted Jun 17, 2024 - 19:42 UTC

Resolved
This incident has been resolved.
Posted Jun 04, 2024 - 23:39 UTC
Investigating
We’re aware of site instability issues and are working on resolving them as soon as possible. We apologize for the inconvenience.
Posted Jun 04, 2024 - 23:06 UTC
This incident affected: Expensify Website And Mobile App.