General Site Instability Issues
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted Dec 02, 2022 - 20:49 UTC
Update
We are continuing to see general slowness issues, and our engineers are working on a permanent solution to remedy any final issues.
Posted Dec 01, 2022 - 21:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 01, 2022 - 05:55 UTC
Identified
Users are currently experiencing some site instability issues. We apologize for the inconvenience and our engineers are working to fix the underlying issue asap!
Posted Nov 30, 2022 - 22:38 UTC
This incident affected: Expensify Website And Mobile App, SmartScan, Integration APIs, and Support Message Deliverability.