Degraded performance for adding Expensify Cards to a mobile wallet (Apply Pay/Android Pay)

Incident Report for Expensify

Resolved

This incident has been resolved.
Posted Aug 08, 2025 - 00:18 UTC

Identified

We are currently experiencing issues with adding Expensify Cards to a mobile wallet (Apply Pay/Android Pay) due to a fault with the Visa network. We are monitoring the issue and will provide an update when this is resolved.
Posted Aug 07, 2025 - 22:20 UTC
This incident affected: Card Import and Feeds (Expensify Card).