Issue adding new deposit-only bank accounts on the latest version of Chrome
Incident Report for Expensify
Resolved
We've pushed out a fix that allows users to add a deposit-only bank on all versions of Chrome.
Posted Aug 21, 2023 - 22:45 UTC
Investigating
We're currently investigating reports that users are unable to add a new deposit-only bank account after upgrading to Chrome version 115 or later.
Posted Aug 21, 2023 - 20:29 UTC
This incident affected: Expensify Website And Mobile App.