Investigating Elevated Site Latency

Incident Report for Expensify

Update

We are continuing to monitor for any further issues.
Posted Mar 01, 2026 - 13:22 UTC

Monitoring

Site performance has returned to baseline and we are continuing to monitor.
Posted Mar 01, 2026 - 04:41 UTC

Investigating

We are currently investigating the cause of site slowness. Actions on the website and mobile app may take longer than usual to complete while we work to identify and resolve the issue.
Posted Mar 01, 2026 - 02:33 UTC
This incident affects: Expensify Website And Mobile App, SmartScan, Report PDFs, Integration APIs, Expensify Chat and Messaging, and SMS Notifications.