Known issue with edited expense amounts.
Incident Report for Expensify
Resolved
This issue has been fixed and we will be reaching out to impacted users. If you have edited your expenses recently please double-check them!
Posted Aug 22, 2023 - 02:31 UTC
Identified
We are aware of an issue where the leading digit is removed from edited expenses (e.g. $1250 becomes $250).

We are currently working on a fix, and will update here when that has been resolved.

In the meantime, please refrain from editing expenses, and reach out to Concierge if you have any questions.
Posted Aug 22, 2023 - 00:41 UTC
This incident affected: Expensify Website And Mobile App.