Degraded Performance
Incident Report for Expensify
Resolved
This incident has been resolved.
Posted Jun 04, 2024 - 22:08 UTC
Update
We are continuing to investigate this issue.
Posted Jun 04, 2024 - 21:50 UTC
Update
We are continuing to investigate this issue.
Posted Jun 04, 2024 - 21:23 UTC
Investigating
We’re aware of site instability issues and are working on resolving them as soon as possible. We apologize for the inconvenience.
Posted Jun 04, 2024 - 14:01 UTC
This incident affected: Expensify Website And Mobile App, Support Message Deliverability, and Expensify Chat and Messaging.